Jak wyświetlić subfora w pionie?

Łukasz | Tagi: , ,

Często zadawanym pytaniem dotyczącym wyglądu MyBB jest w jaki sposób wyświetlić subfora w pionie. Bardzo łatwo można to osiągnąć.

Na samym początku musisz zmienić liczbę wyświetlanych subforów, aby wszystkie pokazały się na stronie głównej. W tym celu w panelu administratora wybierz Konfiguracja, a następnie Opcje strony głównej. Pod Liczba poddziałów wyświetlanych na stronie głównej wpisz liczbę suforów, które mają się wyświetlać przy działach.

Edycja szablonów

Następnie musisz zmienić kilka linii kodu html, w panelu administratora wybierz Style i Szablony, później Szablony i na końcu z paczek szablonów wybierz Opis działu – Szablony. Usuń całą zawartość szablonu forumbit_depth3 i wklej do niego

<li>{$statusicon}<a href="{$forum_url}" title="{$forum_viewers_text_plain}">{$forum['name']}</a></li>

Wróć do paczki szablonów Opis działu – Szablony, usuń całą zawartość szablonu forumbit_subforums i wklej do niego

<br />{$lang->subforums}<br /><ul class="ver_sub">{$sub_forums}</ul>

Edycja CSS

W panelu administratora wybierz Style i Szablony, później Style, wybierz swój styl i na końcu wybierz arkusz global.css. Z górnej zakładki wybierz Edytuj CSS: tryb zaawansowany.

  • Na końcu kodu CSS wstaw poniższy kod, aby subfora wyświetlały się w jednej kolumnie.
.ver_sub {
margin: 0;
padding: 0;
list-style: none;
}
.ver_sub li {
width: 100%;
float: left;
}
  • Jeżeli chcesz aby subfora wyświetlały się w dwóch kolumnach wstaw kod
.ver_sub {
margin: 0;
padding: 0;
list-style: none;
}
.ver_sub li {
width: 50%;
float: left;
}
  • Jeżeli chcesz aby subfora wyświetlały się w trzech kolumnach wstaw kod
.ver_sub {
margin: 0;
padding: 0;
list-style: none;
}
.ver_sub li {
width: 33%;
float: left;
}
  • Jeżeli chcesz aby subfora wyświetlały się w czterach kolumnach wstaw kod
.ver_sub {
margin: 0;
padding: 0;
list-style: none;
}
.ver_sub li {
width: 25%;
float: left;
}






komentarzy 19 »
  1. Ramza (17 lipca 2009, 23:26 ) #

    Dobry poradniczek, bardzo mi się przydał.

  2. DamYan (24 lipca 2009, 20:31 ) #

    W tytule jest błąd – powinno być – „w pionie”.

  3. kamilo (9 stycznia 2010, 21:47 ) #

    Usunęło mi przez przypadek cały arkusz global.css i chciałem przywrócić i osunąłem ;] Sobie problemów narobiłem ;/

  4. Łukasz (9 stycznia 2010, 22:26 ) #

    To akurat nie jest winą poradnika.

  5. kamilo (11 stycznia 2010, 20:06 ) #

    Wklejam ten kod na 2 kolumny i mam jedną ;/
    I potem już nie mam tego kodu w tym CSS tryb zaawansowany, to tak powinno być? ;]

  6. Łukasz (11 stycznia 2010, 22:43 ) #

    Napisz na forum, podaj adres forum i inne szczegóły.

  7. kamilo (12 stycznia 2010, 18:54 ) #

    Napisałem na forum.
    Czy w tym kodzie nie ma błędu?
    Sprawdzałem u siebie na 2 stylach i lipa.

  8. Wojtek (2 lutego 2010, 20:55 ) #

    U mnie śmiga.

  9. Joana (15 marca 2010, 8:20 ) #

    Dobry poradnik,zamiast li można użyć kodu dla ikonek 🙂

  10. Mybboarder (1 kwietnia 2010, 19:42 ) #

    a jak zrobić aby to li(.ver_sub li {
    ) zastąpić jakimś małym obrazkiem ,czy ikonką bo ta kropka li to koszmar

  11. Łukasz (1 kwietnia 2010, 20:10 ) #

    Ta kropka to obrazek sygnalizujący nowe posty, a nie znacznik li. Kod CSS, który musisz wstawić zawiera list-style: none;, więc znaczniki li nie są wyświetlane. Jeżeli chcesz zmienić te punkty, musi podmienić images/minioff.gif oraz images/minion.gif
    Od pomocy technicznej mamy forum

  12. decybl (7 maja 2010, 11:23 ) #

    Niestety ja mam obrazki podstawione a kropki sa przy ikonkach.
    Dodatkowo chcialem aby bylo wyswietlane w dwuch kolumnach a wyswietla sie w jednej, ktos wi dlaczego tak jest ??

  13. Łukasz (7 maja 2010, 22:46 ) #

    @decybel: wstawiłeś odpowiedni kod CSS. Zapraszam na nasze forum: forum.mybbsite.pl

  14. elroyalo (22 marca 2011, 21:42 ) #

    jeśli są problemy z tymi CSS wystarczy wpierw skopiować je do notatnika i potem z niego dopiero do Panelu Administratora.
    Formatowanie zostanie usunięte i skopiuje się sam text

  15. xyzqqweqw (31 października 2011, 0:58 ) #

    Po dodaniu kodu na koniec do global.css nie zapisuje go… wie ktos czemu?

  16. kubaszekr38 (15 grudnia 2012, 17:11 ) #

    A czy da się zmienić kolor tych kropek/kółek obok subfor? Bo ja bym chciał mieć je na kolor żółty. Proszę o pomoc!

  17. zulhan (21 lipca 2013, 9:32 ) #

    Super sprawa i robota dzięki.
    Jak zawsze dobra robota:)

  18. Snake_ (23 kwietnia 2015, 21:04 ) #

    Jezu ludzie macie problem to tak jak pisał Łukasz , zakladajcie nowe watki na forum :).

    Pozdrawiam.

    PS. Szukam chłopaka , jestem gejem.

  19. Krystian (31 sierpnia 2015, 4:21 ) #

    Super poradnik, dzięki 😉

Dodaj komentarz

XHTML: Możesz użyć tagów: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>


Prosimy nie zgłaszać swoich problemów poprzez komentarze! W przypadku problemów zapraszamy nasze forum.

Serwis MyBBsite.pl wykorzystuje cookies. Korzystanie z witryny oznacza zgodę na ich zapis lub wykorzystanie, więcej informacji w polityce prywatności
Akceptuję politykę prywatność, zamknij informację